понедельник, 22 ноября 2010 г.

Парадокс дней рождения

Парадокс дней рождения — утверждение, гласящее, что если дана группа из 23 или более человек, то вероятность того, что хотя бы у двух из них дни рождения (число и месяц) совпадут, превышает 50 %. Для группы из 60 или более человек вероятность совпадения дней рождения хотя бы у двух её членов составляет более 99 %. (подробнее на Википедии).

Доказательство приводить не будем, а в Excel смоделируем.

В ячейке A1 введем функцию =СЛУЧМЕЖДУ(1;365).
(Чтобы ее использовать должна быть подключена надстройка "Пакет анализа".)

Скопируем ее вниз до 45 строки включительно.
Таким образом мы получим 45 случайных чисел от 1 до 365.

Теперь, чтобы выделить повторения воспользуемся условным форматированием.

Заходим в меню "ФОРМАТ - УСЛОВНОЕ ФОРМАТИРОВАНИЕ".
Из выпадающего списка выбираем "формула".
И записываем такую формулу =СЧЁТЕСЛИ($A$1:$A$45;A1)>1 
А дальше устанавливаем нужный формат, к примеру, ШРИФТ красным цветом.

Формат этой ячейки копируем на расположенные ниже ячейки.

Кнопкой "DELELE" можно менять случайные числа в таблице.

P.S. Вообще-то это не является парадоксом в известном смысле и математически все просто и строго доказывается. Но этот пример показывает абсурдность всякого рода совпадений в датах, показывая что "невероятность" такого совпадения как раз таки вероятна.

Похожие по тематике посты - еще почитать:

Комментариев нет:

Отправить комментарий