суббота, 6 ноября 2010 г.

Нумерология. Считаем в Excel


Пишем в ячейке A1 ФИО.

Копируем в ячейку B1 такую формулу:

=СУММ(НАЙТИ(СТРОЧН(ПСТР(ПОДСТАВИТЬ(A1;" ";"");СТРОКА(ДВССЫЛ("1:"&ДЛСТР(ПОДСТАВИТЬ(A1;" ";""))));1));"абвгдеёжзийклмнопрстуфхцчшщъыьэюя")) 

Она содержит массивы, поэтому нажимаем одновременно CTRL + SHIFT + ENTER


В ячейку C1 копируем формулу, которая суммирует цифры числа из ячейки B1:

=СУММ(ПСТР(B1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(B1)));1)*1)

Содержит массивы, поэтому ввод через CTRL + SHIFT + ENTER


И в ячейку D1 следующую формулу, которая суммирует цифры числа из ячейки C1:

=СУММ(ПСТР(C1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(C1)));1)*1) 


Содержит массивы, поэтому ввод через CTRL + SHIFT + ENTER


Результат



Чтобы посмотреть как работают формулы, используем "Меню" - "Сервис" - "Зависимости формул" - "Вычислить формулу" и смотрим как по шагам она выполняется.



Похожие по тематике посты - еще почитать:

Комментариев нет:

Отправить комментарий