среда, 17 ноября 2010 г.

Число 153

  1. Возьмем ЛЮБОЕ положительное целое число.
  2. Умножим исходное число на 3. 
  3. Сложим возведенные в куб цифры полученного числа.
  4. Повторим пункт 3 с получившимся числом.
  5. Через какое-то количество итераций придем к числу 153. Всегда!
Проверим в Excel.

В ячейке A1 напишем =СЛУЧМЕЖДУ(1;3333).
Эта формула возвращает случайное число от 1 до 3333.
Должна быть включена надстройка "Пакет анализа".

В ячейке A2 напишем =A1*3.

В ячейке A3 напишем =СУММ(ПСТР(A2;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(A2)));1)^3).
Это формула содержит массивы, поэтому после окончания ввода нужно нажать CTRL+SHIFT+ENTER.

Пояснение.
СТРОКА(ДВССЫЛ("1:"&ДЛСТР(A2)) создает массив последовательных целочисленных значений, начиная с 1 до ДЛСТР(A2), т.е. длины строки A2. Функция ПСТР() разбивает нашу строку на массив символов, которые мы возводим в 3 степень (^3) и затем суммируем СУММ().

Об использовании массивов можно прочитать на оффициальном сайте MS Office.

Теперь выполним пункт 5., а именно скопируем ячейку A3 вниз до 15-й строки.

Изменить случайное число в первой ячейке можно нажимая клавишу "DELETE".

Мы ВСЕГДА будем приходить в итоге к числу 153.
Я этого доказывать не буду, но написанного выше достаточно, чтобы сделать это самостоятельно.

Похожие по тематике посты - еще почитать:

Комментариев нет:

Отправить комментарий