вторник, 19 июля 2011 г.

Определяем простое ли число с помощью формул массива

Использование массивов позволяют упростить многие вычисления.
В частности все манипуляции, описанные в статье "Является ли число простым", можно заменить одной формулой.

Пусть в ячейке A1 находится число и нужно проверить простое ли оно. Достаточно в ячейку B1 ввести такую формулу:

=ЕСЛИ(МИН(ОСТАТ(A1;СТРОКА(ДВССЫЛ("2:"&ОКРУГЛ(КОРЕНЬ(A1);)))))=0;"составное";"простое")

Можно пойти еще дальше и записать в ячейке C1 формулу:

=СУММ(--(ОСТАТ(A1;СТРОКА(ДВССЫЛ("1:"&A1)))=0))

Эта формула покажет сколько у числа в ячейке A1 делителей.
Например, для числа 12 количество делителей будет 6, а именно 1, 2, 3, 4, 6 и само число 12.


Указанные формулы используют массивы, поэтому после окончания ввода нужно нажать CTRL+SHIFT+ENTER.

Похожие по тематике посты - еще почитать:

3 комментария:

  1. Скажите пожалуйста, как решить такую задачу:

    Есть EXEL файл. В нем 2 столбца. Строки содержат email адреса. В 1м столбце список из всех email адресов. Во 2м столбце список отписавшихся email адресов. Мне нужно удалить из 1го столбца всех отписавшихся, находящихся во 2м столбце.

    ОтветитьУдалить
  2. С помощью функции СЧЁТЕСЛИ() определяем сколько раз адрес из первого списка встречается во втором списке и используем АВТОФИЛЬТР.

    ОтветитьУдалить
  3. Этот комментарий был удален автором.

    ОтветитьУдалить