среда, 29 июня 2011 г.

Выборочное суммирование с использованием СУММЕСЛИ() и СУММПРОИЗВ()

Пусть есть таблица, содержащая объемы реализации складов в зависимости от даты.



Нужно найти сумму реализации "Склада 2" по датам, меньшим заданной даты, для примера по дням, меньшим 15.06.2011г.


Это можно сделать сделать с помощью специальной функции СУММЕСЛИ().

СУММЕСЛИ(диапазон; критерий; диапазон_суммирования)

Диапазон — диапазон вычисляемых ячеек. Эти ячейки будут проверяться на соответствие условию.

Критерий — критерий в форме числа, выражения или текста, определяющего суммируемые ячейки.

Диапазон_суммирования  — фактические ячейки для суммирования. Размер этого диапазона должен совпадать с размером диапазона, проверяемого согласно критерия.

Применив эту функцию, получим



Но если суммировать нужно по нескольким складам, например 1 и 2 складу, то формула запишется в виде суммы

=СУММЕСЛИ(A2:A13;"<15.06.2011";B2:B13)+СУММЕСЛИ(A2:A13;"<15.06.2011";C2:C13)

А если суммировать по 4 складам , то получим в формуле 4 слагаемых,  что не очень удобно.

Можно сделать столбец, в котором будет построчная сумма нужных столбцов и использовать его в качестве диапазона_суммирования.


Можно использовать функцию СУММПРОИЗВ().

СУММПРОИЗВ(массив1; массив2; массив3; ...)

Массив1, массив2, массив3,... — от 2 до 30 массивов, чьи компоненты нужно перемножить, а затем сложить.

Только у нас будет сформирован 1 массив, элементы которого просуммируются




При несмежных столбцах формула будет такая (по складам 1, 3 и 6):

=СУММПРОИЗВ((A2:A13<ДАТА(2011;6;15))*(B2:B13+D2:D13+G2:G13))

либо такая

=СУММПРОИЗВ((A2:A13<ДАТА(2011;6;15))*1; B2:B13+D2:D13+G2:G13)


Похожие по тематике посты - еще почитать:

Комментариев нет:

Отправить комментарий